独闷闷网

 找回密码
 立即注册
搜索
查看: 5787|回复: 8
收起左侧

[求助] 鸿哥,我把你的第六节程序烧进去不好用呢

[复制链接]
发表于 2014-8-15 09:11:16 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 waphaoyun 于 2014-8-15 09:25 编辑

我把鸿哥的 第六节:在主函数中利用累计主循环次数来实现独立按键的检测。  
程序烧进去,,按 S1 和 S5建  蜂鸣器都不响    我测试过 按键和 蜂鸣器 都是好用的
求助。。。@jianhong_wu

我的开发板是在朱总那里购买的第二版开发板!  
乐于分享,勇于质疑!
发表于 2014-8-15 09:33:48 | 显示全部楼层
没用过这板子,你确定烧写程序是这个程序吗?烧写成功了?还有,板子需要设置哪些吗?估计既然鸿哥上传的代码肯定会测试过的
乐于分享,勇于质疑!
发表于 2014-8-15 09:49:13 | 显示全部楼层
可能是我用的版本跟你用的版本有细微差异。你把驱动蜂鸣器的电平取反后试试。假如我原来是用高电平驱动,你就用低电平驱动蜂鸣器。假如我原来是用低电平驱动,你就用高电平去驱动蜂鸣器。
乐于分享,勇于质疑!
发表于 2014-8-15 09:49:43 | 显示全部楼层
可能是我用的版本跟你用的版本有细微差异。你把驱动蜂鸣器的电平取反后试试。假如我原来是用高电平驱动,你就用低电平驱动蜂鸣器。假如我原来是用低电平驱动,你就用高电平去驱动蜂鸣器。
乐于分享,勇于质疑!
 楼主| 发表于 2014-8-15 11:59:16 | 显示全部楼层
jianhong_wu 发表于 2014-8-15 09:49
可能是我用的版本跟你用的版本有细微差异。你把驱动蜂鸣器的电平取反后试试。假如我原来是用高电平驱动,你 ...

鸿哥,好像不是你说的问题,我这么写 按键时蜂鸣器就会响呢,为啥你的程序烧进去就不行呢,感觉鸿哥按键这块按键处理的思路很清晰很合理呢

如图
鸿哥.png
乐于分享,勇于质疑!
 楼主| 发表于 2014-8-15 12:01:32 | 显示全部楼层
黑夜之狼 发表于 2014-8-15 09:33
没用过这板子,你确定烧写程序是这个程序吗?烧写成功了?还有,板子需要设置哪些吗?估计既然鸿哥上传的代 ...

谢谢你的回复  我感觉程序也是测试过的,,不过就是蜂鸣器不响,,我写了个简单的测试一下 硬件应该没问题!
鸿哥.png
乐于分享,勇于质疑!
发表于 2014-8-15 15:14:04 | 显示全部楼层
waphaoyun 发表于 2014-8-15 12:01
谢谢你的回复  我感觉程序也是测试过的,,不过就是蜂鸣器不响,,我写了个简单的测试一下 硬件应该没问 ...

我刚刚专门把我的第6节下载到我的学习板上,很正常的。你那边的现象确实比较奇怪,你再找找原因。
乐于分享,勇于质疑!
 楼主| 发表于 2014-8-16 10:11:38 | 显示全部楼层
jianhong_wu 发表于 2014-8-15 15:14
我刚刚专门把我的第6节下载到我的学习板上,很正常的。你那边的现象确实比较奇怪,你再找找原因。

找到原因了,谢谢鸿哥!
乐于分享,勇于质疑!
发表于 2014-8-16 12:46:15 | 显示全部楼层
waphaoyun 发表于 2014-8-16 10:11
找到原因了,谢谢鸿哥!

是什么原因?跟我分享一下。
乐于分享,勇于质疑!
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|独闷闷网 ( 粤ICP备12007667号-2 )

GMT+8, 2021-7-31 10:38 , Processed in 0.204265 second(s), 20 queries .

快速回复 返回顶部 返回列表