独闷闷网

 找回密码
 立即注册
搜索
查看: 2590|回复: 1
收起左侧

[原创] 51单片机RAM还没有用完而C51编译器却提示不够?用Compact模式。

[复制链接]
发表于 2014-9-12 20:54:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 jianhong_wu 于 2015-1-29 15:20 编辑

风雪--重庆:
RAM用了132字节,编译不过了,如何设置Keil环境中C51编译器的Compact模式?

鸿哥解答:
我以前也遇到过这种现象,那时用的ram大概超过127个字节左右就编译没通过。解决方法是:点击Keil的"Project"下拉菜单,选择“options for target”,在弹出的窗口中再选择“target”栏目,在Memory Model 中点击下拉菜单就可以选择Compact模式了。
RAM不够.jpg

乐于分享,勇于质疑!
发表于 2014-9-12 20:59:35 | 显示全部楼层
多谢鸿哥!
乐于分享,勇于质疑!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|独闷闷网 ( 粤ICP备12007667号-2 )

GMT+8, 2021-6-18 11:10 , Processed in 0.142719 second(s), 21 queries .

快速回复 返回顶部 返回列表